AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog
Subscribe in a reader


Join or renew today and receive a free t-shirt or tech CD, see details in the join the club section at www.mgclub.org!

Author Topic: Wiring - 1977 MGB Right side marker lamps out and fuel pump  (Read 6582 times)

0 Members and 1 Guest are viewing this topic.

pmurphy

  • Message Board Member but not an AMGBA Club Member
  • *
  • Posts: 1
Wiring - 1977 MGB Right side marker lamps out and fuel pump
« on: September 21, 2007, 05:51:44 PM »
My 1977 MGB would not start (no gas getting to the carb), nor would the passenger side marker lights work. I have checked the connections and replaced the fuel pump, but no luck.  All other electrical components work fine. Any suggestions on the culprit.

Art

  • chfwrench
  • AMGBA Club Tech Staff
  • ****
  • Posts: 264
  • Memberhsip Number (if known):: 91-10014
  • MG information: '73 red B roadster
Re: Wiring - 1977 MGB Right side marker lamps out and fuel pump
« Reply #1 on: September 25, 2007, 12:56:49 AM »
The pump has a ground cable to one of the securing bolts for the rear license plate bracket.  It attaches inside the trunk to the back side of the bolt.  If the pump is not "ticking", this could be the culprit.  Especially if you have just painted the car, make sure this connection to ground is good and the wire is secure to the connector. 

A bad connection could defeinitely stop the pump (and the car), I know that from experience.  The light I'm less certain about, but it is the local ground connection for the harness.

I hope that helps you.  Good luck.

Art
Art Isaacs
AMGBA Tech Staff
chfwrench@aol.com


 

   AMGBA website home page or AMGBA Photo Gallery or AMGBA Club Blog